re = /^(?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n]+)/im
str = 'http://mplay.google.co.in/sadfask/asdkfals?dk=10
http://lplay.google.co.in/sadfask/asdkfals?dk=10
http://play.google.co.in/sadfask/asdkfals?dk=10
http://tplay.google.co.in/sadfask/asdkfals?dk=10
http://www.google.co.in/sadfask/asdkfals?dk=10
http://www.google.co.in:8080/sadfask/asdkfals?dk=10
http://username:password@hostname/abcd/foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end