using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:(?:[^\""]*\""){2})*[^\""]*$)(?![^{]*})(?![^[]*\]),+";
string input = @"""text1"":""text2"",""text3"":""text,4"",""text,5"":[""text6"",""text,7""],""text8"":""text9"",""text10"":{""text11"":""text,12"",""text13"":""text14"",""text,15"":[""text,16"",""text17""],""text,18"":""text19""}
""ke,y"":{""key,2"":""val,ue""},""te,st"":""h,i""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}