re = /(?=(?:(?:[^\"]*\"){2})*[^\"]*$)(?![^{]*})(?![^[]*\]),+/m
str = '"text1":"text2","text3":"text,4","text,5":["text6","text,7"],"text8":"text9","text10":{"text11":"text,12","text13":"text14","text,15":["text,16","text17"],"text,18":"text19"}
"ke,y":{"key,2":"val,ue"},"te,st":"h,i"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end