import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(On\\s.*<\\n){0,1}(.*\\n(\\n){0,1}((^>+\\s?.*$)+\\n?)+)";
final String string = "test comment reply in email\n\n"
+ "On 10.05.2016 16:06, MRKTNG wrote:\n"
+ "> New Message\n"
+ "> MRKTNG <#> \n"
+ ">\n"
+ "> Your Profile Picture\n"
+ ">\n"
+ "> Lisa Radzishevsky <#>\n"
+ "> May 10, 2016, 8:06 am\n"
+ ">\n"
+ "> \n"
+ ">\n"
+ "> \n"
+ ">\n"
+ "> RE: Language learning\n"
+ ">\n"
+ "> test subject\n"
+ ">\n"
+ "> \n"
+ "> Reply \n"
+ "> <http://mandrillapp.com/track/click/30047086/vendori.local?p=eyJzIjoiLXVwS2lWRndOUXVibWozbmFVQ09qbVE3ZVdjIiwidiI6MSwicCI6IntcInVcIjozMDA0NzA4NixcInZcIjoxLFwidXJsXCI6XCJodHRwOlxcXC9cXFwvdmVuZG9yaS5sb2NhbFxcXC9kb2N1bWVudFxcXC80ODEwNCNkaXNjdXNzaW9uXCIsXCJpZFwiOlwiY2YwYWFhNWE1ZWY5NDZmMDhlNjJmNmRiMTAyZDY4Y2VcIixcInVybF9pZHNcIjpbXCJhYzE1OWI2NTM2YTM0ZDkzYmU1MzE5Y2VmN2IzOWEwZGQzMjY2NWRkXCJdfSJ9> \n"
+ ">\n"
+ ">\n"
+ "> © 2015 MRKTNG. All Rights Reserved.\n"
+ "> 1 W Superior St. • Chicago • IL 60654 USA <#>\n"
+ ">\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}