$re = '/(On\s.*<\n){0,1}(.*\n(\n){0,1}((^>+\s?.*$)+\n?)+)/mi';
$str = 'test comment reply in email
On 10.05.2016 16:06, MRKTNG wrote:
> New Message
> MRKTNG <#>
>
> Your Profile Picture
>
> Lisa Radzishevsky <#>
> May 10, 2016, 8:06 am
>
>
>
>
>
> RE: Language learning
>
> test subject
>
>
> Reply
> <http://mandrillapp.com/track/click/30047086/vendori.local?p=eyJzIjoiLXVwS2lWRndOUXVibWozbmFVQ09qbVE3ZVdjIiwidiI6MSwicCI6IntcInVcIjozMDA0NzA4NixcInZcIjoxLFwidXJsXCI6XCJodHRwOlxcXC9cXFwvdmVuZG9yaS5sb2NhbFxcXC9kb2N1bWVudFxcXC80ODEwNCNkaXNjdXNzaW9uXCIsXCJpZFwiOlwiY2YwYWFhNWE1ZWY5NDZmMDhlNjJmNmRiMTAyZDY4Y2VcIixcInVybF9pZHNcIjpbXCJhYzE1OWI2NTM2YTM0ZDkzYmU1MzE5Y2VmN2IzOWEwZGQzMjY2NWRkXCJdfSJ9>
>
>
> © 2015 MRKTNG. All Rights Reserved.
> 1 W Superior St. • Chicago • IL 60654 USA <#>
>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);