# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!(\?)|(\[)).+(\n|$)//gm;t' <<< "this is paragraph line1
?[question_2]{\"category\":[]}[who are you]=[] {1,2}
[] OPTION 1
[] OPTION 2
[] OPTION 3
this is paragraph line3
?[question_3]{\"category\":[]}[picode]=_ [PLACEHOLDER_TEXT]
?[question_1]{\"category\":[]}[sex]=() {1}
() male
() femele
this is paragraph line3"