import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(\\?)|(\\[)).+(\\n|$)";
final String string = "this is paragraph line1\n\n"
+ "?[question_2]{\"category\":[]}[who are you]=[] {1,2}\n"
+ "[] OPTION 1\n"
+ "[] OPTION 2\n"
+ "[] OPTION 3\n\n"
+ "this is paragraph line3\n\n"
+ "?[question_3]{\"category\":[]}[picode]=_ [PLACEHOLDER_TEXT]\n\n"
+ "?[question_1]{\"category\":[]}[sex]=() {1}\n"
+ "() male \n"
+ "() femele \n\n\n"
+ "this is paragraph line3";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}