#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+?)$\n^(?=\1\:\w+?)"
Local $sString = "db_unknown" & @CRLF & _
"cdbm01" & @CRLF & _
"oec0005u1" & @CRLF & _
"oec0008q1" & @CRLF & _
"oec0009q1" & @CRLF & _
"oec0015q1" & @CRLF & _
"oec0016q1" & @CRLF & _
"oec0205q1" & @CRLF & _
"oec0206q1" & @CRLF & _
"oec0209q1" & @CRLF & _
"oec0217q1" & @CRLF & _
"oec0218q1" & @CRLF & _
"oec0222q1" & @CRLF & _
"oec0224q1" & @CRLF & _
"oec0225q1" & @CRLF & _
"oec0282q1" & @CRLF & _
"oec0355q1" & @CRLF & _
"oec0374q1" & @CRLF & _
"oec0385q1" & @CRLF & _
"oec0388q1" & @CRLF & _
"oec0409q1" & @CRLF & _
"oec0419q1" & @CRLF & _
"oec0420q1" & @CRLF & _
"cdbm01" & @CRLF & _
"oec0005u1" & @CRLF & _
"oec0008q1" & @CRLF & _
"oec0009q1" & @CRLF & _
"oec0015q1" & @CRLF & _
"oec0016q1" & @CRLF & _
"oec0206q1" & @CRLF & _
"oec0209q1" & @CRLF & _
"oec0225q1" & @CRLF & _
"oec0374q1" & @CRLF & _
"oec0385q1" & @CRLF & _
"oec0388q1" & @CRLF & _
"oec0409q1" & @CRLF & _
"oekngtest1" & @CRLF & _
"oec0355q1" & @CRLF & _
"oec0462q2" & @CRLF & _
"oec0463q2" & @CRLF & _
"oec0464q2" & @CRLF & _
"oec0482q2" & @CRLF & _
"oec0496q2" & @CRLF & _
"oec0497q2" & @CRLF & _
"oec0499q2" & @CRLF & _
"oec0506q2" & @CRLF & _
"oec0511q2" & @CRLF & _
"oec0519q2" & @CRLF & _
"oec0529q2" & @CRLF & _
"oec0547q2" & @CRLF & _
"oec0553q2" & @CRLF & _
"oec0555q2" & @CRLF & _
"oec0667q2" & @CRLF & _
"oec0670q2" & @CRLF & _
"db1db2" & @CRLF & _
"db1db2" & @CRLF & _
"oec0462q2" & @CRLF & _
"oec0463q2" & @CRLF & _
"oec0464q2" & @CRLF & _
"oec0482q2" & @CRLF & _
"oec0496q2" & @CRLF & _
"oec0497q2" & @CRLF & _
"oec0499q2" & @CRLF & _
"oec0506q2" & @CRLF & _
"oec0511q2" & @CRLF & _
"oec0519q2" & @CRLF & _
"oec0529q2" & @CRLF & _
"oec0547q2" & @CRLF & _
"oec0553q2" & @CRLF & _
"oec0555q2" & @CRLF & _
"oec0667q2" & @CRLF & _
"oec0670q2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")