import re
regex = re.compile(r"^(\w+?)$\n^(?=\1\:\w+?)", flags=re.MULTILINE)
test_str = ("db_unknown\n"
"cdbm01\n"
"oec0005u1\n"
"oec0008q1\n"
"oec0009q1\n"
"oec0015q1\n"
"oec0016q1\n"
"oec0205q1\n"
"oec0206q1\n"
"oec0209q1\n"
"oec0217q1\n"
"oec0218q1\n"
"oec0222q1\n"
"oec0224q1\n"
"oec0225q1\n"
"oec0282q1\n"
"oec0355q1\n"
"oec0374q1\n"
"oec0385q1\n"
"oec0388q1\n"
"oec0409q1\n"
"oec0419q1\n"
"oec0420q1\n"
"cdbm01\n"
"oec0005u1\n"
"oec0008q1\n"
"oec0009q1\n"
"oec0015q1\n"
"oec0016q1\n"
"oec0206q1\n"
"oec0209q1\n"
"oec0225q1\n"
"oec0374q1\n"
"oec0385q1\n"
"oec0388q1\n"
"oec0409q1\n"
"oekngtest1\n"
"oec0355q1\n"
"oec0462q2\n"
"oec0463q2\n"
"oec0464q2\n"
"oec0482q2\n"
"oec0496q2\n"
"oec0497q2\n"
"oec0499q2\n"
"oec0506q2\n"
"oec0511q2\n"
"oec0519q2\n"
"oec0529q2\n"
"oec0547q2\n"
"oec0553q2\n"
"oec0555q2\n"
"oec0667q2\n"
"oec0670q2\n"
"db1db2\n"
"db1db2\n"
"oec0462q2\n"
"oec0463q2\n"
"oec0464q2\n"
"oec0482q2\n"
"oec0496q2\n"
"oec0497q2\n"
"oec0499q2\n"
"oec0506q2\n"
"oec0511q2\n"
"oec0519q2\n"
"oec0529q2\n"
"oec0547q2\n"
"oec0553q2\n"
"oec0555q2\n"
"oec0667q2\n"
"oec0670q2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")