const regex = /^[a-z]{1,3}-[a-z]{1,2}-(\d){1,4}$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]{1,3}-[a-z]{1,2}-(\\d){1,4}$', 'i')
const str = `ASL-MO-9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}