import re
regex = re.compile(r"^[a-z]{1,3}-[a-z]{1,2}-(\d){1,4}$", flags=re.IGNORECASE)
test_str = "ASL-MO-9"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")