const regex = /(\$line\[)(?!\d|\$\w|[^\]]*const)([^\]]+)(\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\$line\\[)(?!\\d|\\$\\w|[^\\]]*const)([^\\]]+)(\\])', 'gm')
const str = `\$line[word_test]
\$line[\$abc]
\$line[a const]
\$line[3]`;
const subst = `$1'$2'$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);