$re = '/(\$line\[)(?!\d|\$\w|[^\]]*const)([^\]]+)(\])/m';
$str = '$line[word_test]
$line[$abc]
$line[a const]
$line[3]';
$subst = "$1'$2'$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;