# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<![\w-])button(?![\w-])/text/g;t' <<< "#button .button large-button tinybutton size9button #9button button-large buttontiny"