$re = '/(?<![\w-])button(?![\w-])/';
$str = '#button .button large-button tinybutton size9button #9button button-large buttontiny';
$subst = "text";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;