#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http|https|ftp)\://([a-zA-Z0-9\-\.]+\.+[a-zA-Z]{2,3})(:[a-zA-Z0-9]*)?/?([a-zA-Z0-9\-\._\?\,\'/\\\+&%\$#\=~]*)[^\.\,\)\(\s]?"
Local $sString = "appro@openssl.org" & @CRLF & _
"appro@openssl.org" & @CRLF & _
"appro@openssl.org" & @CRLF & _
"appro@openssl.org" & @CRLF & _
"appro@openssl.org" & @CRLF & _
"http://www.openssl.org/support/faq.html" & @CRLF & _
"www.openssl.org/support/faq.html" & @CRLF & _
"http://www.openssl.org/support/faq.html" & @CRLF & _
"d.compressedData" & @CRLF & _
"https://" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.001" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.001" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.002" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.002" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.003" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.003" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.004" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.004" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.005" & @CRLF & _
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.005" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.001" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.001" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.002" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.002" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.003" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.003" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.004" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.004" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.005" & @CRLF & _
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.005" & @CRLF & _
"http://err.allnetserveline.com" & @CRLF & _
"http://err.allnetserveline.com" & @CRLF & _
"http://logs.allnetserveline.com" & @CRLF & _
"http://logs.allnetserveline.com" & @CRLF & _
"http://stats.allnetserveline.com" & @CRLF & _
"http://stats.allnetserveline.com" & @CRLF & _
"http://js.allnetserveline.com/crossbrowse/js/{{camp_id}}/{{secret}}/ch.js" & @CRLF & _
"http://js.allnetserveline.com/crossbrowse/js/{{camp_id}}/{{secret}}/ch.js" & @CRLF & _
"http://srch.allnetserveline.com/crossbrowse/sch/{{camp_id}}/{{secret}}/ch.json" & @CRLF & _
"http://srch.allnetserveline.com/crossbrowse/sch/{{camp_id}}/{{secret}}/ch.json" & @CRLF & _
"http://js.allnetserveline.com/crossbrowse/js/{{camp_id}}/{{secret}}/ch.js" & @CRLF & _
"http://js.allnetserveline.com/crossbrowse/js/{{camp_id}}/{{secret}}/ch.js" & @CRLF & _
"http://srch.allnetserveline.com/crossbrowse/sch/{{camp_id}}/{{secret}}/ch.json" & @CRLF & _
"http://srch.allnetserveline.com/crossbrowse/sch/{{camp_id}}/{{secret}}/ch.json" & @CRLF & _
"http://update.allnetserveline.com/crossbrowse/updater/{{camp_id}}/{{version}}/{{secret}}/update.json" & @CRLF & _
"http://update.allnetserveline.com/crossbrowse/updater/{{camp_id}}/{{version}}/{{secret}}/update.json" & @CRLF & _
"http://ipgeoapi.com/" & @CRLF & _
"http://ipgeoapi.com/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")