const regex = /<(\w+)[^>]+>\n*([\s\S]*)<\/\1>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)[^>]+>\\n*([\\s\\S]*)<\\\/\\1>', '')
const str = `<location maps="">
RewriteMap map txt:map.txt
RewriteMap lower int:tolower
RewriteCond %{REQUEST_URI} ^/([^/.]+)\\.html\$ [NC]
RewriteCond \${map:\${lower:%1}|NOT_FOUND} !NOT_FOUND
RewriteRule .? /index.php?q=\${map:\${lower:%1}} [NC,L]
</location>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}