re = /<(\w+)[^>]+>\n*([\s\S]*)<\/\1>/
str = '<location maps="">
RewriteMap map txt:map.txt
RewriteMap lower int:tolower
RewriteCond %{REQUEST_URI} ^/([^/.]+)\\.html$ [NC]
RewriteCond ${map:${lower:%1}|NOT_FOUND} !NOT_FOUND
RewriteRule .? /index.php?q=${map:${lower:%1}} [NC,L]
</location>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end