$re = '/\$\$[^\W+]\w+$/';
$str = 'select * from asdf where asdf.starttime = #test# $$test';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);