re = /\$\$[^\W+]\w+$/
str = 'select * from asdf where asdf.starttime = #test# $$test'
# Print the match result
str.match(re) do |match|
puts match.to_s
end