$re = '/(?<!(\d|\-))(?<!(\d\,))(([012]?[0-9])[\:]([012345]?[0-9])([\:]([012345]?[0-9]))?|([012]?[0-9])[\-]([012345]?[0-9])([\-]([012345]?[0-9]))?|([012]?[0-9])[\—]([012345]?[0-9])([\—]([012345]?[0-9]))?)\b/u';
$str = '09:10 вкл. Л27-7, откл. Р27-7-3(с.Мариинск), бригада работает
В 13:20 вкл. Л 27-1"Беш-Озек", откл. Р 27-1-5, животноводческие стоянки, осмотр продолжается.
Объект: КП-2 ВЛ 6 № 16 Класс напряжения: 6 кВ Тип события: Аварийное Время возникновения события (ур.вр.): 10.01.2016 06:11 Описание работы РЗ и ПА: КП-2, ВЛ 6 № 16, МТЗ, АПВ-О, АВР-нет Причина технологического нарушения: В пр. оп. № 23-1-23-2 замыкание ВЛ в результате падения ветки тополя..
Причина срыв вязки оп. 24-01/82.
Остается обесточено абонентское ОП 29-1 (абоненты <Асфальтный завод> и <Янтарьлес>).
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);