import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?<!(\d|\-))(?<!(\d\,))(([012]?[0-9])[\:]([012345]?[0-9])([\:]([012345]?[0-9]))?|([012]?[0-9])[\-]([012345]?[0-9])([\-]([012345]?[0-9]))?|([012]?[0-9])[\—]([012345]?[0-9])([\—]([012345]?[0-9]))?)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
09:10 вкл. Л27-7, откл. Р27-7-3(с.Мариинск), бригада работает
В 13:20 вкл. Л 27-1"Беш-Озек", откл. Р 27-1-5, животноводческие стоянки, осмотр продолжается.
Объект: КП-2 ВЛ 6 № 16 Класс напряжения: 6 кВ Тип события: Аварийное Время возникновения события (ур.вр.): 10.01.2016 06:11 Описание работы РЗ и ПА: КП-2, ВЛ 6 № 16, МТЗ, АПВ-О, АВР-нет Причина технологического нарушения: В пр. оп. № 23-1-23-2 замыкание ВЛ в результате падения ветки тополя..
Причина срыв вязки оп. 24-01/82.
Остается обесточено абонентское ОП 29-1 (абоненты <Асфальтный завод> и <Янтарьлес>).
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)