using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^第]([ -~φθ°α’−]+)(?![個])";
string input = @" 第2の装置1gbは、実施の形態9においてその詳細を説明した装置1であって、1 + Y個のMOSトランジスタを備える。各MOSトランジスタの状態は、保護IC 88により制御される。
そして、9以上のMOSトランジスタを備えてもよいし、11以上のMOSトランジスタを備えてもよいし、N以上のMOSトランジスタを備えてもよい。
そして、8個のMOSトランジスタを備えてもよいし、12個のMOSトランジスタを備えてもよいし、N個のMOSトランジスタを備えてもよい。";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}