import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^第]([ -~φθ°α’−]+)(?![個])";
final String string = " 第2の装置1gbは、実施の形態9においてその詳細を説明した装置1であって、1 + Y個のMOSトランジスタを備える。各MOSトランジスタの状態は、保護IC 88により制御される。\n"
+ " そして、9以上のMOSトランジスタを備えてもよいし、11以上のMOSトランジスタを備えてもよいし、N以上のMOSトランジスタを備えてもよい。\n"
+ " そして、8個のMOSトランジスタを備えてもよいし、12個のMOSトランジスタを備えてもよいし、N個のMOSトランジスタを備えてもよい。";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}