using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<inverted>!)?\s*(?<name>--?\w[\w-]*)\s*(?<values>(?:\s*(?:\w\S*|[""'](?:[^""'\\]*(?:\\.[^""'\\]*)*)['""]))*)\K";
string input = @"-a val1 ! -b value-with-dash --custom ""string with crazy -a --test stuff inside"" --param-with-dash val1 val2 -c ! -d ! --test -t -g d";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}