const regex = /(?<inverted>!)?\s*(?<name>--?\w[\w-]*)\s*(?<values>(?:\s*(?:\w\S*|["'](?:[^"'\\]*(?:\\.[^"'\\]*)*)['"]))*)\K/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<inverted>!)?\\s*(?<name>--?\\w[\\w-]*)\\s*(?<values>(?:\\s*(?:\\w\\S*|["\'](?:[^"\'\\\\]*(?:\\\\.[^"\'\\\\]*)*)[\'"]))*)\\K', 'g')
const str = `-a val1 ! -b value-with-dash --custom "string with crazy -a --test stuff inside" --param-with-dash val1 val2 -c ! -d ! --test -t -g d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}