package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[+-]?\d+\.\d+`)
var str = `1.23 , 1 , .023 , -1 , -1. , -1.1 , + 1.123, `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}