$re = '/[+-]?\d+\.\d+/m';
$str = '1.23 , 1 , .023 , -1 , -1. , -1.1 , + 1.123, ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);