package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ssh.([^\s]+)`)
var str = `ssh de-esn-vm-404 dddfdfdfdfg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}