$re = '/^ssh.([^\s]+)/m';
$str = 'ssh de-esn-vm-404 dddfdfdfdfg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);