import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?![a-zA-ZÀ-ž\\d\\s\\.,'&/-]).)";
final String string = "!@$%^*&^&*()_-.>\n\n"
+ "- , . ' & /\n"
+ "abcdefghijklmopqrstuvwxyz \n"
+ "ABCDEFGHIJKLMNOPQRSTUVW\n"
+ "1234567890\n"
+ "_[]\"\\?<>!@#$%^*()\n"
+ "áäâàæãåāçéëêèęėēíïìîįīj́ñńóöôòõœøōúüûùū\n"
+ "ÁÄÂÀÆÃÅĀÇÉËÊÈĘĖĒÍÏÌÎĮĪJ́ÑŃÓÖÔÒÕŒØŌÚÜÛÙŪ\n\n"
+ "Paradijslaan\n"
+ "64\n"
+ "B\n"
+ "3034 SP\n"
+ "Rotterdam\n"
+ "Luxemburgstraat\n"
+ "41\n"
+ "A\n"
+ "1363 BK\n"
+ "Almere\n"
+ "Klarinet\n"
+ "6\n"
+ "5231 DL\n"
+ "'s-HertogenboschNoordstraat\n"
+ "42-a\n"
+ "5038 EJ\n"
+ "Tilburg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}