const regex = /((?![a-zA-ZÀ-ž\d\s\.,'&/-]).)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?![a-zA-ZÀ-ž\\d\\s\\.,\'&\/-]).)', 'gm')
const str = `!@\$%^*&^&*()_-.>
- , . ' & /
abcdefghijklmopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVW
1234567890
_[]"\\?<>!@#\$%^*()
áäâàæãåāçéëêèęėēíïìîįīj́ñńóöôòõœøōúüûùū
ÁÄÂÀÆÃÅĀÇÉËÊÈĘĖĒÍÏÌÎĮĪJ́ÑŃÓÖÔÒÕŒØŌÚÜÛÙŪ
Paradijslaan
64
B
3034 SP
Rotterdam
Luxemburgstraat
41
A
1363 BK
Almere
Klarinet
6
5231 DL
's-HertogenboschNoordstraat
42-a
5038 EJ
Tilburg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}