import re
regex = re.compile(r"(\.(?=[\s\n\r]|$))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Unfortunately, this removed all other 'dots' as well. My paragraph includes dates like Jan.13, 2014 , words like U.S and numbers like 2.2. How can I remove only the full stops?\n\n"
"Somthing is there. \n\n"
"Hello someone . What is this something ? ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")