re = /(\.(?=[\s\n\r]|$))/mi
str = 'Unfortunately, this removed all other \'dots\' as well. My paragraph includes dates like Jan.13, 2014 , words like U.S and numbers like 2.2. How can I remove only the full stops?
Somthing is there.
Hello someone . What is this something ? '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end