# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/abc(?:(?!abc).)*?xyz//s;t' <<< "abc 1 abc 2 xyz"