import re
regex = re.compile(r"abc(?:(?!abc).)*?xyz", flags=re.DOTALL)
test_str = "abc 1 abc 2 xyz"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)