const regex = /^(\+\d{1,3}[- ]?)?\d{15}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+\\d{1,3}[- ]?)?\\d{15}$', '')
const str = `https://drive.google.com/drive/folders/1O_3BcrkpKUtl9xrDHEY3DwS4r7Ll0v9e?usp=drive_link`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}