use strict;
my $str = 'https://drive.google.com/drive/folders/1O_3BcrkpKUtl9xrDHEY3DwS4r7Ll0v9e?usp=drive_link';
my $regex = qr/^(\+\d{1,3}[- ]?)?\d{15}$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}