const regex = /[^\s-]-\K\R(?=[^\s-])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\s-]-\\K\\R(?=[^\\s-])', 'gm')
const str = `This is a ice-
cream and this is a car `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);