re = /[^\s-]-\K\R(?=[^\s-])/m
str = 'This is a ice-
cream and this is a car '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result