using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?<=^- ))[^*\n-]+?(?= ::)";
string input = @"question :: answer # should match 'question'
question ::answer # should match ' question'
**question** :: answer # should not match
*question* :: answer # should not match
- question :: answer # should only match 'question' and not '- question'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}