import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=^- ))[^*\\n-]+?(?= ::)";
final String string = "question :: answer # should match 'question'\n"
+ "question ::answer # should match ' question'\n"
+ "**question** :: answer # should not match\n"
+ "*question* :: answer # should not match\n"
+ "- question :: answer # should only match 'question' and not '- question'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}