import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<src_host>\\w+\\.\\w+:\\d{2})\\s(?<src_ip>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})\\D{1,6}(?<date_time>[^ ]+)\\s(?<GMT_offset>[^ ]+)\\]\\s\"(?<action>(GET|POST|HEAD|TRACE|PUT|DELETE|CONNECT))\\s(?<hash_url>[^ ]+)\\s(?<protocol>[^\\\"]+)\\\"\\s(?<code>\\d{1,3})\\s(?<size>[^ ]+)\\s\\\"(?<referrer>[^ ]+)\\\"\\s\\\"(?<user_agent>[^ ]+.+)\\\"";
final String string = "google.com:80 212.111.203.171 - - [02/Mar/2015:10:27:04 +0000] \"GET /css/style.css HTTP/1.1\" 304 138 \"http://google.com\" \"Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}