import Foundation
let pattern = #"(?<src_host>\w+\.\w+:\d{2})\s(?<src_ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\D{1,6}(?<date_time>[^ ]+)\s(?<GMT_offset>[^ ]+)\]\s"(?<action>(GET|POST|HEAD|TRACE|PUT|DELETE|CONNECT))\s(?<hash_url>[^ ]+)\s(?<protocol>[^\"]+)\"\s(?<code>\d{1,3})\s(?<size>[^ ]+)\s\"(?<referrer>[^ ]+)\"\s\"(?<user_agent>[^ ]+.+)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"google.com:80 212.111.203.171 - - [02/Mar/2015:10:27:04 +0000] "GET /css/style.css HTTP/1.1" 304 138 "http://google.com" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)