#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(\w*\$)[\s]*(\/[\w]*)[\s]*([\w\s]*)\n\s*([\w\\]*)[\s\/]*([\w\s]*).*^(\w*\$)\s*([\w\/\-]*)\s*([\w \-\/]*)[\n\s]*([\w\/\-\\]*)[\s\/]*([\w\s]*)\n\s*([\w\/\-\\]*)[\s\/]*([\w\/\-\\ ]*)\n([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)"
Local $sString = " " & @CRLF & _
" " & @CRLF & _
"Name Mount Point Description" & @CRLF & _
"---- ----------- -----------" & @CRLF & _
"ETC$ /etc Remote Administration" & @CRLF & _
" BUILTIN\Administrators / Full Control" & @CRLF & _
"C$ / Remote Administration" & @CRLF & _
" BUILTIN\Administrators / Full Control" & @CRLF & _
" HYDROQC\APPL-NETAPP-ADMIN / Full Control" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^(ETC\$)[\s]*(\/[\w]*)[\s]*([a-zA-Z\s]*)\n\s*([\w\\]*)[\s\/]*([a-zA-Z\s]*)\n^(C\$)[\s]*(\/[\w]*)[\s]*([\w\s]*)\n(?:\s*([\w\\]*)[\s\/]*([a-zA-Z\s]*)\n)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")