import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w*\\$)[\\s]*(\\/[\\w]*)[\\s]*([\\w\\s]*)\\n\\s*([\\w\\\\]*)[\\s\\/]*([\\w\\s]*).*^(\\w*\\$)\\s*([\\w\\/\\-]*)\\s*([\\w \\-\\/]*)[\\n\\s]*([\\w\\/\\-\\\\]*)[\\s\\/]*([\\w\\s]*)\\n\\s*([\\w\\/\\-\\\\]*)[\\s\\/]*([\\w\\/\\-\\\\ ]*)\\n([\\s\\^\\(\\w\\\\\\$\\)\\[\\]\\*\\/\\-\\?\\:]*)";
final String string = " \n"
+ " \n"
+ "Name Mount Point Description\n"
+ "---- ----------- -----------\n"
+ "ETC$ /etc Remote Administration\n"
+ " BUILTIN\\Administrators / Full Control\n"
+ "C$ / Remote Administration\n"
+ " BUILTIN\\Administrators / Full Control\n"
+ " HYDROQC\\APPL-NETAPP-ADMIN / Full Control\n\n\n\n\n\n\n\n\n\n"
+ "^(ETC\\$)[\\s]*(\\/[\\w]*)[\\s]*([a-zA-Z\\s]*)\\n\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n^(C\\$)[\\s]*(\\/[\\w]*)[\\s]*([\\w\\s]*)\\n(?:\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}