package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[[^]]+\]|[^,]+)`)
var str = `a,[b,c,d], e(f), g(h + i) = j, a + c = g(e)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}