$re = '/(\[[^]]+\]|[^,]+)/';
$str = 'a,[b,c,d], e(f), g(h + i) = j, a + c = g(e)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);