using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[flag(?!.*\[flag)(.*?)\]";
string input = @"This is a string with a [flag NO MATCH] that should match [flag THIS] but dont want this [NO NO]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}