$re = '/\[flag(?!.*\[flag)(.*?)\]/m';
$str = 'This is a string with a [flag NO MATCH] that should match [flag THIS] but dont want this [NO NO]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);